Issue with Payment Processing

Incident Report for BCycle

Monitoring

A new version of the BCycle app, 5.10.3, has been released to handle this issue on iOS and Android. Users encountering currency conversion issues should be advised to update to the latest version of the app. All users with automatic updates should receive this version over the coming days. Users can find the app version in the app stores and on the About BCycle page in the BCycle app.
Posted Jun 03, 2026 - 22:19 CDT

Identified

We have identified an issue with payment processing in the mobile app on iOS devices. For users who are checking out on a device with a non-U.S. region selected, transactions will be sent to Stripe for an incorrect U.S. dollar value. We are working on a fix and will continue to update as we prepare to release a new app version and resolve this issue.
Posted Jun 02, 2026 - 19:19 CDT
This incident affects: BCycle Mobile App.